How do I use PostgreSQL extensions on Enclave?

By default, the Aptible Docker PostgreSQL Docker image we use to provision PostgreSQL databases only includes the PostGIS extension. If you’d like to use other extensions, we maintain an alternative Docker image that includes some of them.

To use that image, contact support and request it.

If you’d like to know what extensions are available in the alternative image, inspect the script we use to install them: install-extras.sh.

If you’d like to request the addition of a new extension, please file an issue on the aptible/docker-postgresql repository, or make a pull request including the extension.

The Enclave Platform